Errors Affecting Zoho & Formstack Connectors
Incident Report for Formstack Sync
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 20:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2020 - 19:45 UTC
Identified
We have identified an issue affecting Zoho and Formstack integrations. We are working to implement a fix for this issue.
Posted Feb 17, 2020 - 16:18 UTC
This incident affected: Connectors (Zoho, Formstack).