Dashboard and Recent Activity Offline
Incident Report for Formstack Sync
Resolved
This incident has been resolved.
Posted Dec 03, 2019 - 18:22 UTC
Investigating
We are currently investigating an issue where clients are unable to access their dashboard and see recent activity.
Posted Dec 03, 2019 - 15:32 UTC
This incident affected: Sync App (frontend).