Partial Outage Affecting Zoho & Formstack Connectors
Incident Report for Formstack Sync
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 19:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2020 - 19:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 19, 2020 - 19:39 UTC
This incident affected: Connectors (Zoho, Formstack).