Degraded ability to access the Sync App
Incident Report for Formstack Sync
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 15:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2020 - 14:58 UTC
Identified
We have identified an issue affecting some customers' ability to access Sync's front end webpage. We are working on a fix to be implemented.
Posted Mar 23, 2020 - 14:13 UTC
This incident affected: Sync App (frontend).