Zoho Connector Incident
Incident Report for Formstack Sync
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 22:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2020 - 22:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 17, 2020 - 21:36 UTC
Investigating
We are investigating an issue keeping Zoho connectors from responding to requests
Posted Feb 17, 2020 - 21:22 UTC
This incident affected: Connectors (Zoho).