Sync Outage
Incident Report for Formstack Sync
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 13:11 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 14, 2019 - 12:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 14, 2019 - 12:20 UTC
Investigating
We are currently investigating this issue.
Posted Nov 14, 2019 - 11:53 UTC
This incident affected: Sync App (frontend).