Trouble Loading Sync Front End
Incident Report for Formstack Sync
Resolved
We have identified the root issue causing the front end issues and it has been resolved.
Posted Mar 16, 2020 - 21:33 UTC
Identified
We have recognized that the issue affecting the front end is continuing. We have identified the issue and are working on a more permanent solution.
Posted Mar 16, 2020 - 20:44 UTC
This incident affected: Sync App (frontend).